5.0.1 little UI feedback

Hello, I want to give some UI feedback since you reworking it. This window has to just go. It would be much better if it will refresh itself automatically upon connect/disconnect image
Also would be nice to include a setting to automatically connect after launch, the less buttons needed to press - the better

1 Like

The 5.0 UI has so many problems I uninstalled it and went back to 4.5.5, the best version.

In 5.0:

  • you can’t get rid of the self-diagnosis window (“100% done!”)
  • it doesn’t auto-connect (neither did 4.6.1)
  • when you do connect it doesn’t automatically refresh the browser
  • the real time RTT graph has no legend and doesn’t show the actual connection speeds
  • there’s no way to easily report problems

How on Earth did anyone at Mudfish think it was good enough to be released?

Okay. @rsod @Potoroo Please test with mudfish v5.0.1 when you get a chance. I’d fixed most of these issues you reported. :slight_smile: Thank you for your feedback and let me know if there’s something wrong or missed. And welcome another feature requests too.

Where can I get 5.0.1? The download links always come back with 4.6.1.

Please find it at https://mudfish.net/releases/ link. I missed to mention the download link. :frowning:

Now that feels better by a very lot, thank you for the changes

uh, actualy, this realtime credit use feels like a bug
image
my account is subscription though anyway
image

:slight_smile: Thank you for your feedback and bug reporting! I’d fixed this issue at code repo so it’ll be fixed when new release is available.

I can’t really find custom item settings now, were they moved somewhere or…?

@rsod Did you turn on Expert Mode and visit ‘Item -> Manage Item’ menu? It still should be at the same place.

yeah, it’s still there, that’s my bad. It’s just my previously created custom item somehow disappeared out of existence which got me confused. I don’t need it right now though and if I need it, I will create it again, so it’s not an issue. Thank you

Hello again. Thanks for all the interface changes. One small change, if you’ll have time, would be nice to add extra confirmation for this reset button:


(and in general for reset buttons)
I hit it twice accidentally

:slight_smile: Thank you for feedback! I’d fixed this issue by changing the UI. It’ll be available at next version.