[Browser Extension] Node / Server List Issue

Are extensions having a problem with finding and connecting to specific servers?

For instance, when I play with my attached item, I can view all the nodes through its Item Configuration.

So, when I use the extension to just limit it to that specific browser, I cannot find it anywhere. If I connect to it using the previous instances saved in the extension history, then I just get redirected elsewhere.

I’ve noticed this happening for more than a week now.

EDIT:
I tried it again just now. I see the usual good nodes—JP Asia (Tokyo - Psychz) for this instance—with (0/0/0) System Load, low traffic, and 0.00% packet loss. It also has the least score available.

I used to be able to connect to it, but it’s not even showing in the server selection.

If I connect to it using the one from recently used servers, then I get reconnected to a different (non-existent?) server which is NL Europe (Amsterdam - HotSailor).

The same thing happens to the old nodes, but it goes to other countries like Brazil.

Both Google Chrome and Microsoft Edge have the same exact problems.

EDIT 2:
All the servers inside the red box are nonexistent when searching for them using the browser extension.
I am using the latest version uploaded as well (v. 4.4.8).

EDIT 3:
If it wasn’t clear enough, Tokyo - Psychz (like all the others inside the box) can’t be seen after Linode4 IDC on the picture above (server list on the browser extension, upper right corner of the picture). It just jumps to SakuraNet 2 right away. This wasn’t the case a few weeks ago, and I didn’t have any new updates on my computer.

@Delirium Could you please access https://mudfish.net/api/staticnodes link from your browser? When I checked the screenshot, it points that the mudfish webextension uses the old cached list of mudfish nodes. :frowning: It means by unknown reason it failed to fetch the newest one.

I accessed the static nodes on both Google Chrome + Microsoft Edge. I wasn’t sure if having the extension running or not made a difference (it did not), so I checked the nodes both ways (extension = on/off).

I can see there are several new nodes, but my browser extension still does not have it.

Is there a manual way to fetch the list?

@Delirium I’m not sure how you’re familiar to load the webextension manually. If it’s possible, please follow the steps:

As you might guess, this is to know what’s going on your box. I’d added “Sync” button at the menubar of mudfish.

I think I know the problem now. Both Microsoft Store and Chrome Web Store do not have the updated version.

I noticed you uploaded 4.4.9 above, but the store versions are 4.4.8. I even tried to check the links on the main website, and it just redirects to these old versions.

Are you able to update the store versions?

EDIT: If you can’t update the store, then can you also upload the latest Microsoft Edge version here?

EDIT 2: I realized, Microsoft Edge can load Chrome-based extensions too. I’ve manually loaded them for both browsers, and I can confirm the servers and the “Sync” button are present. Thank you for that. However, I hope we get a directory of sorts on the website for browser extension versions—and not just a redirect to the store—unless the store gets updated as well.

EDIT 3: Out of curiosity, I checked the Firefox Browser Add-ons page, and it has v. 4.4.9 while the other two are still at v. 4.4.8.

@Delirium v4.4.9 is the latest beta version of mudfish webextensioin so it’s not registered at this moment at the official webstore. I’ll try to update this version. :slight_smile:

FYI however it takes some times because Google requires some code review before publishing the version if the webextension uses a proxy feature.

Thank you for articulating the situation. I was just musing about scenarios, and I wasn’t implying any rush. I appreciate the help! :slight_smile: