Frequent RTO to FFXIV Elemental Data Center

Hi,

Since the last maybe 3-4 days I’ve been getting frequent RTOs when connecting to the Elemental data center in FFXIV. I’ve tried quite a number of nodes, mostly the ones in Singapore, and I’ve also tried the auto selection option, but none seem to remove the issue. I’m using a full subscription mode and am connecting from Jakarta. Mudfish generally works great with me with very little issue, it’s just that this problem has been persistent since it popped up.

As you can see in the screenshot below, the ping is generally fine and there are no spikes, just random RTOs. I don’t get these RTOs when I disable mudfish, so I’m quite sure this isn’t an issue with my ISP. I’ve also tried switching my connection to hotspot from my phone and the same issue occurs: frequent RTOs without any lag spikes when using mudfish.

Is there anything I can do, or maybe a setting I’ve missed?

Thank you, any help would be much appreciated!

Please try to test your network status from your desktop to 124.150.157.1 (FF XIV: A Realm Reborn - Asia (Japan - ELEMENTAL)) using How to use WinMTR link. I think you need to do two tests; one without mudfish and another with mudfish connected.

I think this result shows you where this issue is from.