Lost ARK RU high Ping

so im playing LOST ARK RU, no matter what nodes or setup program i use the ping is above 250 and have alot of spike. also after updating mudfish to the 5.0.4 the advance mode node not working only displaying 1 node instead 2 node…
this ping didnt have any different with free VPN like softether.

how can i reduce my ping ?

Did you try to change a mudfish node based on FAQ - Nodes section for your game item? If you’re using the advanced mode, please start with the basic mode.

However please check your ISP too. When I checked RTT information recorded in Mudfish, it seems RTT stddev values to most of the mudfish nodes are quite unstable. It means your ISP has a network issue. For details please check http://ko.loxch.com/userrtt/?uid=394507 link.

um, are there anything i can do about my isp example ? ( what i need to tell to my ISP ?) or is it beyond help ? sorry im really noob about networking like this.
im using advance mode because it help me reduce my ping signnificantly around (40-80 ping).

thanks for answering…

Yeah I`m having the same issue. I had 250 stable a couple of hours then it spiked to 266, and now its between 300-350.

I bought this vpn because some people recommended it, but im getting worse ping than ExitLag(I was getting 233, max 250)

Same here, getting a lot of spikes from 62ms to 90ms and sometimes even up to 150+. With Exitlag free trial I get consistent 62ms to Moscow servers.

I tried every Moscow server from Mudfish (with Basic Mode) and each give me horrible spikes. It seems to be the traffic to the servers since the Realtime Traffic chart has the same spikes like the Realtime RTT chart.

yup same here, ping keep spiking in last 2 days, can someone from mudfish take a look about this problem?

and this morning, the ping is okay-ish, but now, it stays at 250-300ms, is there something wrong with the server?

all of my friends also experiencing the same problem, high ping and packet loss to RU server, playing Lost Ark

Same for me here. Connecting from asia. Getting ping spikes from a node that was totally stable before and now I have to find a different node to connect to.

I cant login with any node except fullVPN mode. Is this situation normal?

No it’s not normal.
I beilieve there are only like 3 or 4 russian nodes that work. Go try out different ones.

I’ve tried every single one of those russian nodes still can’t login. It’s weird because I connected from asia too.

I found what the problem is. It’s proxy mode, in the login application.

Can we get some reply from the Mudfish team? Still getting spikes from all Moscow servers whereas I get steady ping with Exitlag. Connecting from Germany.