Please change this conditions

change conditions libopenssl1.1 to libopenssl

arm_cortex-a9_vfpv3-d16

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for mudfish-pi:
  •  libopenssl1.1
    
  • opkg_install_cmd: Cannot install package mudfish-pi.
    (install libopenssl1.1 my router many errors,auto update,…
    thanks

What’s your OpenWRT version? and which router model are you trying to install? It seems you’re using 1) a un-supported OpenWRT version or 2) a wrong arch package to install.

yes
my openwrt 19.7.7 , router Turris Omnia
root@turris:~# cat /proc/cpuinfo
processor : 0
model name : ARMv7 Processor rev 1 (v7l)
BogoMIPS : 1600.00
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpd32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x4
CPU part : 0xc09
CPU revision : 1

processor : 1
model name : ARMv7 Processor rev 1 (v7l)
BogoMIPS : 1600.00
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpd32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x4
CPU part : 0xc09
CPU revision : 1

Hardware : Marvell Armada 380/385 (Device Tree)
Revision : 0000
Serial

root@turris:~# opkg print-architecture
arch all 1
arch noarch 1
arch arm_cortex-a9_vfpv3-d16 10

(((customizied OpenWRT distribution)))
install this
/releases/openwrt/packages-19.07/arm_cortex-a9_vfpv3-d16/

@sloon Okay. Then you’re not using the official OpenWRT 19.07 distribution on the router, right? If your OpenWRT version was customized by your router provider, we can’t support your router at this moment because its dependency is up to your distribution.

If possible, please try to install the official OpenWRT version and test.