Unable to access Mudfish without using a VPN

Hello there,

I’ve tried to access and login to my Mudfish account today, but I get a connection error every time I try to enter my credentials. If I have Mullvad VPN connected, however, I’m able to log in and establish a connection as I usually would.

Is it possible that there two programs are interfering with each other? I find it unlikely since the mudfish.com website also doesn’t load, and it’s the only thing that I seem to be having connection issues with.



More information :

Going to www.mudfish.net results in a "An error occurred during a connection to www.mudfish.net. " message.

If I log in while having a VPN on, then turn it off and refresh the page, Mudfish is unable to connect and gives me the “There was a problem loading the page. Do you want to load the screen again?” error.

If I establish a connection with a VPN on, it’ll mostly be stable but I get the occasional 00459 errors.

I also can’t access mudfish.net on my phone with the same wifi, but it works when I use my phone data.

I am located in Taiwan and my ISP is Chunghwa Telecom Co.,Ltd.

1 Like

i also cant use mudfish unless i have a vpn on

Update :

Everything Mudfish related still blocked.

@SnowFire @skillunit When you get a chance, please test it again. I think your public IP were blocked for a while to prevent DoS attack.

If it’s still the same, please let me know your current public IP. I’ll check it for you.

1 Like

Seems to have been the case, I can access mudfish services now.

Thank you for the update!

1 Like

Seems my IP has been blocked again.

Is this a regular occurence for Mudfish users? This is the second time this has happened in less than a week.

Is there a way to ensure this won’t happen again? If not, I’d like to get a refund issued.

Thank you!

When this issue happens again, please let me know your public IP. I’m not sure that where your issue is from at this point.